iEDGE Compatible with DSi Firmware 1.4 (UK / EURO / Japan / Pal version)
11/17/2009

Team EDGE stopped the production of EDGE for DS Lite in Sep 2009 as they were about to lauch the new version of iEDGE for the DSi. The iEDGE and EDGE are multi functional media adapters for DSi, DSL and DS.

Online PR News – 17-November-2009 – – Team EDGE stopped the production of EDGE for DS Lite in Sep 2009 as they were about to lauch the new version of iEDGE for the DSi. The iEDGE and EDGE are multi functional media adapters for DSi, DSL and DS. www.xpertron.co.uk

Features:

* Supports DSi/DSL/DS
* Fully upgrade-able bootstrap via onboard CPU

* Supports DSi firmware v1.4+
* Plays homebrew NDS ROMS
* Frequently updated OS for best compatibility
* In game reset
* Full download play support
* Automatic ROM protection patcher
* SlowMotion mode
* Save game saves directly to Micro SD
* Automatic save game type detection
* Supports MicroSDHC cards up to 32GB
* Multimedia playback such as movies and MP3's
* Action Replay compatible cheat system
* Multi language user interface
* Micro SDHC card reader included

www.m3izero.co.uk

A snapshot of the iEDGE introduction by the EDGE Team:
The DSi has completely updateable firmware, meaning it is possible that in the future a firmware update will be released which will block iEDGE along with all other competing products. For this reason it is vital that when a DSi firmware update is released, you DO NOT install this update until we, the EDGE Team, have verified that the firmware update is safe to install. Our website displays the most recent DSi firmware version supported by iEDGE – DO NOT install a DSi firmware update more recent (i.e: a higher version number) than that which is listed. If such a firmware update is released in the future, a new iEDGE bootstrap will be released to combat the update. In this case you must install the new iEDGE bootstrap BEFORE installing the new DSi firmware update. Failure to do so may result in your iEDGE being blocked by the DSi; if this happens then you will need either a DS Lite or a DSi with older firmware to successfully update the bootstrap.

Initial Setup
In order to meet compliance with universal copyright laws, we have taken a completely legal approach for our iEDGE product. Competing products distribute flash content which contains illegally distributed partial ROM images (required for booting on DSi) which are needed as part of the bootstrap data.
We have designed our product in such a way as the user may merge the required ROM data with the iEDGEbootstrap data in order to generate a file containing the required ROM data. In this way iEDGE can be legally distributed, meaning that customers and distributors will not face the risk of the product being seized at customs and border controls. This bootstrap file creation only has to be completed once for normal usage, or when the user must update to a new bootstrap version (for example, if an old bootstrap gets blocked by a future DSi firmware update). The documentation accompanying each bootstrap release will list the required ROM file.

Note that bootstrap data is different from the iEDGE OS. The bootstrap data is the content required to actually boot iEDGE, whereas the OS is the software which executes the user functionality of iEDGE. The OS is stored on the MicroSD card and is trivially updated by simply copying the relevant files. The first time you use iEDGE, you must first install the bootstrap and then secondly copy the iEDGE OS files onto your MicroSD card. Once these two steps are completed, your iEDGE is ready to use.

Source: http://www.m3izero.co.uk/iedge-ds-for-uk-eu-pal-dsi-and-nds-lite-edgei.html